Ziffern beliebiger Anordnung aus einem Text extrahieren

07/09/2007 - 10:56 von Doris Mayrhofer | Report spam
Hallo,

ich muss aus einem Text (z.B. LEHNIGK MICHAEL THOMAS COPY -
AGENTUR - SHOP VETSCHAU (40132
07 01 01) Ziffern extrahieren, und zwar die Kundennr. In diesem Fall
ist das 40132.
Ich habe es mit der Formel
{=SUMME((TEIL(0&A1;KGRÖSSTE(WENN(ISTZAHL(TEIL(0&A1;ZEILE(1:256);1)*1);ZEILE(1:256);1);ZEILE(1:256));1)*1)*10^(ZEILE(1:256)-1))}
versucht. Leider erfolglos. Ich habe die Matrixformel auch mit Feststell,
Strg + enter beendet.. klappte trotzdem nicht.
Ausserdem nehme ich an, dass diese Formel auch die anderen Ziffern (07 01
01) extrahiert hàtte, was nicht weiter schlimm gewesen wàre, da hàtte ich mir
ja mit der TEIL Funktion dann abhelfen können.

Was hab ich falsch gemacht bzw. gibts eine Alternativ-Lösung für mein Problem?

Besten Dank im voraus für die Hilfe!

Gruß,
Doris
 

Lesen sie die antworten

#1 Claus Busch
07/09/2007 - 11:11 | Warnen spam
Hallo Doris,

Am Fri, 7 Sep 2007 01:56:02 -0700 schrieb Doris Mayrhofer:

ich muss aus einem Text (z.B. LEHNIGK MICHAEL THOMAS COPY -
AGENTUR - SHOP VETSCHAU (40132
07 01 01) Ziffern extrahieren, und zwar die Kundennr. In diesem Fall
ist das 40132.
Ich habe es mit der Formel
{=SUMME((TEIL(0&A1;KGRÖSSTE(WENN(ISTZAHL(TEIL(0&A1;ZEILE(1:256);1)*1);ZEILE(1:256);1);ZEILE(1:256));1)*1)*10^(ZEILE(1:256)-1))}
versucht. Leider erfolglos. Ich habe die Matrixformel auch mit Feststell,
Strg + enter beendet.. klappte trotzdem nicht.
Ausserdem nehme ich an, dass diese Formel auch die anderen Ziffern (07 01
01) extrahiert hàtte, was nicht weiter schlimm gewesen wàre, da hàtte ich mir
ja mit der TEIL Funktion dann abhelfen können.



die Formel ist mit STRG+Shift+Enter abzuschließen. Dann extrahiert sie dir
aber alle Zahlen, in deinem Beispiel als 40132070101.
Wenn dein String aber immer gleich aufgebaut ist und die beiden Zahlen in
Klammern stehen, würde schon dies reichen:
=--TEIL(A1;FINDEN("(";A1)+1;8)
Mit dem letzten Argument, der Lànge des Teilstrings kannst du noch etwas
experimentieren, da ich nicht weiß, wie viele Leerzeichen zwischen den
beiden Zahlen sind.


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP2 / Vista Ultimate
Office 2003 SP2 / 2007 Ultimate

Ähnliche fragen