Zirkelbezug -> Iteration?

24/07/2014 - 19:21 von Peter Schuerer | Report spam
Hallo Zusammen (Claus),

XL2002.

In AJ4:AJ34 stehen Zahlen, in AJ35 wird die Summe aus AJ4:AJ34 berechnet
und in AJ36 der Mittelwert von AJ4:AJ34.
Jetzt kommt es:
Wenn in D4:D34 irgend wo "DS" auftaucht, soll in der entsprechenden
Zeile der Wert aus AJ36 eingetragen werden, sonst soll mit folgender
Formel berechnet werden.

=WENN(C4="";"";WENN(D4="DS";$AJ$36;SUMMENPRODUKT((DBProd!$A$3:$A$5995=$A4)*(DBProd!$B$3:$B$5995=$AT$1)*(DBProd!$C$3:$C$5995=$C4);DBProd!$Y$3:$Y$5995)+(SUMME(R4;T4;V4)*1,24)))

Wenn in D4 der Text "DS" steht, liefert diese Formel einen Zirkelbezug.
Diesen habe ich mit der Iteration (Maximale Anzahl = 1) ausgeschaltet
(überlistet).

Kann man das so machen oder überliste ich mich das selbst?
Gibt es eine andere Lösung?

Danke und Gruß
Peter
 

Lesen sie die antworten

#1 Claus Busch
24/07/2014 - 19:33 | Warnen spam
Hallo Peter,

Am Thu, 24 Jul 2014 19:21:20 +0200 schrieb Peter Schuerer:

In AJ4:AJ34 stehen Zahlen, in AJ35 wird die Summe aus AJ4:AJ34 berechnet
und in AJ36 der Mittelwert von AJ4:AJ34.
Jetzt kommt es:
Wenn in D4:D34 irgend wo "DS" auftaucht, soll in der entsprechenden
Zeile der Wert aus AJ36 eingetragen werden, sonst soll mit folgender
Formel berechnet werden.



ich kann das nicht nachvollziehen. In welcher Spalte soll denn das
Ergebnis rein? Ziehst du die Formel von Zeile 4 bis 34?

Lass mal den Summenproduktteil weg und probiere es nur mit:
=WENN(C4="";"";WENN(D4="DS";$AJ$36;""))
Wo soll da ein Zirkelbezug herkommen? Oder steht in Spalte D eine
Formel, die sich auf Spalte AJ bezieht?


Mit freundlichen Grüßen
Claus
Vista Ultimate / Windows7
Office 2007 Ultimate / 2010 Professional

Ähnliche fragen