Zugriff Oracle 10g XE über ASP.NET

25/01/2009 - 12:19 von Bruti | Report spam
Hallo,

ich weiß leider nicht mehr weiter. Ich hab seit 2 tagen folgendes Problem.
Ich bekomme mit einer einfachen ASP.NET anwendung keinen Connect zu Oracle
hin.

ich bekomme immer die Fehlermeldung: ORA-12154: TNS could not resolve
service name, der Connect über SQL-plus klappt problemlos.
Desweiteren hab ich dann eine einfach Webformsanwendung geschrieben, die nur
einen connect zur datenbank macht und das klappt auch ohne weiteres.
Ich bekomme aber auch über der ServerExplorer von Visual Studio keinen
connect zur datenbank hin.

Ich habe schon ein paar mal die odp.net komponenten deinstaliert und
installiert, hab jedem benutzer schreib und leserechte auf das komplette
Oracle verzeichnis gegeben aber nichts klappt.

Ich bin nun wirklich mit meinem latein am ende, hat vielleicht jemand noch
einen Tipp für mich?


Mein Betriebsystem ist Vista64 bit.

Viele Grüße und danke

Thomas
 

Lesen sie die antworten

#1 Carsten Cerny
29/01/2009 - 16:15 | Warnen spam
Bruti schrieb:

ich weiß leider nicht mehr weiter. Ich hab seit 2 tagen folgendes Problem.
Ich bekomme mit einer einfachen ASP.NET anwendung keinen Connect zu Oracle
hin.

ich bekomme immer die Fehlermeldung: ORA-12154: TNS could not resolve
service name, der Connect über SQL-plus klappt problemlos.



Hast du eine TNSNAMES.ORA und eine SQLNET.ORA auf deinem Rechner
($ORACLE_HOME/network/admin/) und entsprechend angepasst?

Das die Webformsanwendung (wahrscheinlich APEX) funktioniert, liegt am
ApplicationServer, auf dem sie làuft. Der braucht keine TNSNAMES.ORA,
weil er nur HTML zum Browser zurückschickt, ohne, dass dein Client oder
eine Oracle-Komponenten darauf beteiligt ist.

Im OTN-Forum
(http://forums.oracle.com/forums/forum.jspa?forumID6&start=0) findest
du mehr Infos.

Grüße,
Carsten

Ähnliche fragen