Zugriffsprobleme in Access, kein Zugriff auf Inhalt der Tabellen

08/02/2008 - 11:35 von stefanbach | Report spam
Guten Tag meine Damen und Herren,

ich habe ein ungewöhnliches Problem mit Access 2000... und bin mittlerweile
so am verzweifeln das ich hier einen kleinen Hilferuf einsetze.

Ich habe eine Accessdatenbank mit dazugehöriger *.mdw Datei. Als erstes was
ich gemacht habe ist mich über Extras -> Sicherheit ->
Arbeitsgruppenadministrator zu der bestehenden *.mdw hinzuzufügen. Das hat
auch wunderbar geklappt, jedesmal wenn ich die Datenbank jetzt öffne fragt er
mich einen Benutzernamen und ein Passwort ab. So soll es auch sein.

Ich logge mich also ein, aber dann ist es mir unmöglich eine Tabelle zu
öffnen. Access bringt mir dann die sehr schlichte Fehlermeldung "fehlt". Mehr
nicht.

Ich habe dann versucht per ASP und JET eine Verbindung mit der Datenbank
aufzunehmen, was im Prinzip auch klappt. Ich kann sogar einfache
SQL-Abfragebefehle ausführen ala "Select * from Tabelle1". Sobald ich aber
eine Abfragebedingung hinten dran setze (where ID = '1') kommt schon wieder
diese tolle Fehlermeldung "fehlt".

Unter Google habe ich nichts gefunden, und auch eine Neuinstallation von
Access mit SP3 hat nichts gebracht. Ich bin echt total ratlos was hier falsch
làuft, zudem diese Fehlermeldung ja überhaupt keinen Anhaltspunkt liefert.
Das einzige was mir noch einfàllt wàren fehlende Benutzerrechte...

Die Datenbank und die Administrationsdatei selbst kommen von einem Kunden.
Muss der bei sich womöglich einen Benutzer anlegen und mir dann alles nochmal
schicken?

mfg Stefan Bach
 

Lesen sie die antworten

#1 Thomas Möller
08/02/2008 - 18:02 | Warnen spam
Hallo Stefan,

stefanbach schrieb:
Ich habe eine Accessdatenbank mit dazugehöriger *.mdw Datei. Als
erstes was ich gemacht habe ist mich über Extras -> Sicherheit ->
Arbeitsgruppenadministrator zu der bestehenden *.mdw hinzuzufügen.
Das hat auch wunderbar geklappt, jedesmal wenn ich die Datenbank
jetzt öffne fragt er mich einen Benutzernamen und ein Passwort ab. So
soll es auch sein.

Ich logge mich also ein, aber dann ist es mir unmöglich eine Tabelle
zu öffnen. Access bringt mir dann die sehr schlichte Fehlermeldung
"fehlt". Mehr nicht.

Ich habe dann versucht per ASP und JET eine Verbindung mit der
Datenbank aufzunehmen, was im Prinzip auch klappt. Ich kann sogar
einfache SQL-Abfragebefehle ausführen ala "Select * from Tabelle1".
Sobald ich aber eine Abfragebedingung hinten dran setze (where ID > '1') kommt schon wieder diese tolle Fehlermeldung "fehlt".

Unter Google habe ich nichts gefunden, und auch eine Neuinstallation
von Access mit SP3 hat nichts gebracht. Ich bin echt total ratlos was
hier falsch làuft, zudem diese Fehlermeldung ja überhaupt keinen
Anhaltspunkt liefert. Das einzige was mir noch einfàllt wàren
fehlende Benutzerrechte...

Die Datenbank und die Administrationsdatei selbst kommen von einem
Kunden. Muss der bei sich womöglich einen Benutzer anlegen und mir
dann alles nochmal schicken?



den Grund für dieses Problem kenne ich auch nicht. Aber lass uns mal
versuchen, das Problem etwas einzugrenzen.

Taucht der Fehler nur auf Deinem Rechner auf? Hast Du die Dateien schon
mal auf einen anderen Rechner kopiert und es dort probiert?

Kann Dein Kunde mit dem von Dir verwendeten Account eine Tabelle öffnen?

CU
Thomas

Homepage: www.Team-Moeller.de

Ähnliche fragen