Zusätzliches Disk für Virtueller Exchange Server 2003 auf W2K3 Clu

30/06/2008 - 11:59 von H. Moghnieh | Report spam
Hallo zusammen

Wir haben einen Exchange Server Cluster von zwei Nodes:
- Windows Server 2003 Enterpris Edition mit SP2, GER
- Microsoft Exchange Server 2003 mit SP2, GER
- Cluster Art: Active/Passive
- Shared Disks im SAN (MSA1500cs)
- Logische Laufwerk: 4 LW

- Physische Laufwerke:
- DISK1, 2x HD 36 GB in Raid10 => Logische Laufwerk-1, 34 GB (Cluster Quorum)
- DISK2, 3x HD 146 GB in Raid5 => Logische Laufwerk-2, 275 GB (Exchange DB)
- DISK3, 2x HD 146 GB in Raid10 => Logische Laufwerk-3, 1136 GB (Exchange
Logs1)
- DISK4, 2x HD 146 GB in Raid10 => Logische Laufwerk-4, 1136 GB (Exchange
Logs2)

Unser Exchange Cluster haben wir im Oktober 2006 aufgebaut / installiert,
alles funktioniert ohne Probleme.
beim Failover (Ausfall erster Node1) übergibt der Cluster Dienst die ganze
Clustergruppe "Mail-Cluster-01" mit Exchange virtual server (EVS) samt
Ressourcen (Sherad Disks, Netzwerkname etc..) an den zweiten Node (2)

Wir möchten den Exchange Cluster mit einem zusàtzlichen logischen Laufwerk
(3x HD 300 GB in Raid5 => LW: 600 GB) erweitern,

- Die neuen HDs sind im SAN bereits integriert und das Logische Laufwerk
auch erstellt.
- in beiden Nodes (Node1 + Node2) ist das neue Laufwerk ersichtlich
"Datentràgerverwaltung"
- auf dem Node1 haben wir das neue LW formatiert und als Cluster Ressource
erstellt (Physikalischen Datentràger), mögliche Besitzer sind beide Nodes

Beim manuellen Failover (neu Start) von Node1 geht die neue Ressource mit
allen anderen Ressourcen zum Node2 über.

Der Exchange virtual Server (EVS) Exchange-Systemaufsicht in der
Clustergruppe "Mail-Cluster-01" ist von folgenden Ressourcen abhàngig:
- Disk2, Disk3, Disk4 und den EVS-Netzwerkname (Mail01)

Ich habe die Clustergruppe "Mail-Cluster-01" Offline geschaltet und die
Abhàngigkeit vom EVS angepasst / erweitert mit dem neuen Disk5 und dann
Online geschaltet
die Clustergruppe "Mail-Cluster-01" geht ohne Probleme Online!

Beim manuellen Failover (neu Start) von Node1 geht die neue Ressource mit
allen anderen Ressourcen zum Node2 ABER die Clustergruppe "Mail-Cluster-01"
startet nicht und bleibt OFFLINE!
das heisst die EVS Exchange-Systemaufsicht wird nicht gestartet und es gibt
keinen Exchange-Server!
das Laufwerk, Disk5 erscheint auf dem Node2 mit dem Vermerk " Unrecognized"
/ "unerkannt" !!!

Diese Konfiguration habe ich bis jetzt zweimal ohne Erfolg durchgeführt,
danach habe ich die Änderungen rückgàngig gemacht und die neue Ressource
"Disk5" gelöscht, nach dem Löschen der Disk-Ressource erscheint beim
Doppelklicken des EVS/VES folgende Fehlermeldung:

<< Bei dem Versuch Seiten von der Erweiterungs-DLL
"{30C5DA98-BA0C-11D2-BC65-00C04FA32177}" hinzufügen, ist ein Fehler
aufgetreten
Schwerwiegender Fehler
Fehlerkennung: -2147418113 >>
in Ereignisanzeige sind keine Fehlermeldungen zu sehen!
Der Exchange Cluster funktioniert weiterhin ohne Problem auch das manuelle
Failover ebenfalls.

Die Fehlermeldung erscheint nur auf beiden Nodes, wenn ich den Cluster vom
Client verwalte erscheint die Fehlermeldung nicht!
Jetzt habe ich neue Disk Ressource in eine neu erstellte Clustergruppe
„Disk-Gruppe“ erstellt und in die Gruppe "Mail-Cluster-01" verschoben, aber
die EVS Abhàngigkeiten noch nicht angepasst.

Meine Fragen:

- Muss man in bereits konfigurierten EVS die Abhàngigkeiten in solchen
Disk-Erweitungsfall anpassen?? darf man das überhaupt? Gemàss Microsoft JA
siehe Bitte
(http://technet.microsoft.com/de-de/...y/aa996400(EXCHG.65).aspx) punkt 7-
Abhàngigkeiten!

- oder genügt die Erstellung der neuen Ressource in der Clustergruppe
"Mail-Cluster-01" mit möglichen Besitzern ohne die Abhàngigkeiten von EVS zu
veràndern?

Wie kann ich die Fehlermeldung beheben?

Besten Dank
 

Lesen sie die antworten

#1 Bernd Pfann [MS]
30/06/2008 - 15:05 | Warnen spam
"H. Moghnieh" <H. wrote in message
news:
Hallo zusammen

Wir haben einen Exchange Server Cluster von zwei Nodes:
- Windows Server 2003 Enterpris Edition mit SP2, GER
- Microsoft Exchange Server 2003 mit SP2, GER
- Cluster Art: Active/Passive
- Shared Disks im SAN (MSA1500cs)
- Logische Laufwerk: 4 LW

- Physische Laufwerke:
- DISK1, 2x HD 36 GB in Raid10 => Logische Laufwerk-1, 34 GB (Cluster
Quorum)
- DISK2, 3x HD 146 GB in Raid5 => Logische Laufwerk-2, 275 GB (Exchange
DB)
- DISK3, 2x HD 146 GB in Raid10 => Logische Laufwerk-3, 1136 GB (Exchange
Logs1)
- DISK4, 2x HD 146 GB in Raid10 => Logische Laufwerk-4, 1136 GB (Exchange
Logs2)

Unser Exchange Cluster haben wir im Oktober 2006 aufgebaut / installiert,
alles funktioniert ohne Probleme.
beim Failover (Ausfall erster Node1) übergibt der Cluster Dienst die ganze
Clustergruppe "Mail-Cluster-01" mit Exchange virtual server (EVS) samt
Ressourcen (Sherad Disks, Netzwerkname etc..) an den zweiten Node (2)

Wir möchten den Exchange Cluster mit einem zusàtzlichen logischen Laufwerk
(3x HD 300 GB in Raid5 => LW: 600 GB) erweitern,

- Die neuen HDs sind im SAN bereits integriert und das Logische Laufwerk
auch erstellt.
- in beiden Nodes (Node1 + Node2) ist das neue Laufwerk ersichtlich
"Datentràgerverwaltung"
- auf dem Node1 haben wir das neue LW formatiert und als Cluster Ressource
erstellt (Physikalischen Datentràger), mögliche Besitzer sind beide Nodes

Beim manuellen Failover (neu Start) von Node1 geht die neue Ressource mit
allen anderen Ressourcen zum Node2 über.

Der Exchange virtual Server (EVS) Exchange-Systemaufsicht in der
Clustergruppe "Mail-Cluster-01" ist von folgenden Ressourcen abhàngig:
- Disk2, Disk3, Disk4 und den EVS-Netzwerkname (Mail01)

Ich habe die Clustergruppe "Mail-Cluster-01" Offline geschaltet und die
Abhàngigkeit vom EVS angepasst / erweitert mit dem neuen Disk5 und dann
Online geschaltet
die Clustergruppe "Mail-Cluster-01" geht ohne Probleme Online!

Beim manuellen Failover (neu Start) von Node1 geht die neue Ressource mit
allen anderen Ressourcen zum Node2 ABER die Clustergruppe
"Mail-Cluster-01"
startet nicht und bleibt OFFLINE!
das heisst die EVS Exchange-Systemaufsicht wird nicht gestartet und es
gibt
keinen Exchange-Server!
das Laufwerk, Disk5 erscheint auf dem Node2 mit dem Vermerk "
Unrecognized"
/ "unerkannt" !!!

Diese Konfiguration habe ich bis jetzt zweimal ohne Erfolg durchgeführt,
danach habe ich die Änderungen rückgàngig gemacht und die neue Ressource
"Disk5" gelöscht, nach dem Löschen der Disk-Ressource erscheint beim
Doppelklicken des EVS/VES folgende Fehlermeldung:

<< Bei dem Versuch Seiten von der Erweiterungs-DLL
"{30C5DA98-BA0C-11D2-BC65-00C04FA32177}" hinzufügen, ist ein Fehler
aufgetreten
Schwerwiegender Fehler
Fehlerkennung: -2147418113 >>
in Ereignisanzeige sind keine Fehlermeldungen zu sehen!
Der Exchange Cluster funktioniert weiterhin ohne Problem auch das manuelle
Failover ebenfalls.

Die Fehlermeldung erscheint nur auf beiden Nodes, wenn ich den Cluster vom
Client verwalte erscheint die Fehlermeldung nicht!
Jetzt habe ich neue Disk Ressource in eine neu erstellte Clustergruppe
„Disk-Gruppe“ erstellt und in die Gruppe "Mail-Cluster-01" verschoben,
aber
die EVS Abhàngigkeiten noch nicht angepasst.

Meine Fragen:

- Muss man in bereits konfigurierten EVS die Abhàngigkeiten in solchen
Disk-Erweitungsfall anpassen?? darf man das überhaupt? Gemàss Microsoft JA
siehe Bitte
(http://technet.microsoft.com/de-de/...y/aa996400(EXCHG.65).aspx) punkt
7-
Abhàngigkeiten!



Ja, der Netzwerkname sollte nicht online gehen wenn die dazu notwendigen
Ressourcen dahinter nicht da sind.

- oder genügt die Erstellung der neuen Ressource in der Clustergruppe
"Mail-Cluster-01" mit möglichen Besitzern ohne die Abhàngigkeiten von EVS
zu
veràndern?

Wie kann ich die Fehlermeldung beheben?

Besten Dank



Wenn Du die neue Disk Ressource in eine extra Gruppe legst - kann diese dann
problemlos zwischen den Nodes hin- und her fallen?

Mit freundlichen Grüßen / Kind regards - Bernd Pfann (Microsoft)

This posting is provided "AS IS" with no warranties, and confers no
rights.

Ähnliche fragen