zwei Listen miteinander vergleichen

15/11/2007 - 11:13 von Bjoern | Report spam
Moin!

Excel 2003 unter XP

Ich habe zwei Excel-Listen, die jeweils gleich aufgebaut sind, aber
unterschiedliche Datensàtze haben. Ich erhalte jede Woche so eine Liste und
muss die Neue mit der jeweils àlteren abgleichen.

in der neuen Liste können neue Datentsàtze hinzugekommen sein, aber auch
alte gelöscht worden sein.

Ich muss jetzt daraus jede Woche zwei Listen erstellen:
-Neu hinzugekommene Datensàtze => Alle Datensàtze, die in der neuen Liste
sind, aber nicht in der Alten
-Gelöschte Datensàtze => Alle Datensàtze, die in der alten Liste sind, aber
nicht (mehr) in der Neuen

Es handelt sich um Listen mit ca. 500 Datensàtzen, das ist also hàndisch
zwar noch machbar aber nicht sinnvoll.
Die Listen liegen jeweils als separate Dateien vor.

Gibt es in Excel eine Funktion, mit der man sowas automatisch machen kann?
Oder ist es besser, die Listen in Access zu importieren? Dort kann ich ja
mittels Abfragen recht schnell die gewünschten Listen bauen.

Freue mich auf zahlreiche Tipps und Anregungen!

Danke und beste Grüße,

Björn
 

Lesen sie die antworten

#1 Alexander Wolff
15/11/2007 - 12:39 | Warnen spam
Ich muss jetzt daraus jede Woche zwei Listen erstellen:
-Neu hinzugekommene Datensàtze => Alle Datensàtze, die in der neuen
Liste sind, aber nicht in der Alten
-Gelöschte Datensàtze => Alle Datensàtze, die in der alten Liste
sind, aber nicht (mehr) in der Neuen



- ein Feld (G) anhàngen: Darin bei "alt" 0, bei "neu" 1 eintragen +
runterkopieren
- Daten untereinander hàngen. Spalte A enthalte das eindeutige Merkmal
- noch ein Feld (H) anhàngen: H2: =ZÄHLENWENN(A:A;A2)=1
- Autofilter H=WAHR und G nacheinander mit =0 und =1 durchführen und die
beiden resultierenden Filtrate wegkopierend sichern. 0 sind die gelöschten,
1 die hinzugekommenen.
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen