Zwei Netzwerke ueber WLAN verbinden

19/10/2008 - 16:57 von Christian Baer | Report spam
Hallo liebe Gruppengemeinde!

wie man es theoretisch macht wurde ja schonmal ausdiskutiert. Jetzt habe
ich mal etwas Hardware eingekauft (einen SE505v1) und wollte dieses WE
loslegen. Nur kurz zur Zusammenfassung: Ich will den Internetzugang
meiner Nachbarin mitbenutzen. Den ganzen Hintergrund gibt es hier:
<gcg78s$n5b$1@nermal.rz1.convenimus.net>

Vorraussetzungen
Hardware (bei mir): SE505v1 mit dd-wrt 24sp1, Fritz 7270 (Hauptrouter)
Hardware (bei ihr): Arcor Easybox A600 WLAN

Die Netzwerke sind getrennt und sollen es auch bleiben. Ich habe nàmlich
keinen Bock, den DHCP-Server für sie zu betreiben. :-) Davon ab kommen
wir uns so nicht in die Quere.
Mein Netz: 192.168.1.0 - Ihr Netz: 192.168.2.0
Subnetmask jeweils 255.255.255.0
Router meiner Nachbarin hat 192.168.2.1, der DHCP-Range beginnt bei 100.

Als Bridge kann mein wrt also nicht funktionieren, sondern muß eher
routen. Ich bin bei der ersten Konfiguration dieser Anleitung gefolgt:
http://www.dd-wrt.com/wiki/index.php/Client_Mode

Folgende Einstellungen habe ich gemacht:
/Wireless/Basic/Wireless Mode: Client
/Wireless/Basic/Wireless Network Mode: G-Only (habe aber auch mixed
probiert)

Dann ist da eine Einstellung, die ich nicht ganz verstehe. Unter Network
Configuration kann man nochmal auswàhlen zwischen Bridged und Unbridged.
Ansich würde ich das ja verstehen, aber warum gibt es die Einstellung
quasi zweimal, nàmlich auch nochmal oben in der Auswahlliste von
Wireless Mode. Da gibt es nàmlich "Client" und Client Bridge". Ich habe
beide Einstellungen ausprobiert. Unbridged habe ich diese Einstellungen
zusàtzlich gesetzt:
IP Address: 192.168.2.50
Subnet Mask: 255.255.255.0
Die SSID habe natürlich auch eingetragen. :-)

Unter /Wireless/Wireless Security/ habe ich WPA2 Personal gewàhlt,
zusammen mit AES und dem entsprechenden PSK (per copy&paste eingesetzt).

Gemàß der Anleitung habe ich dann unter
/Setup/Basic Setup/Wireless Setup/WAN Connection Type/ Static IP
gesetzt. Dazu diese Zahlen:
WAN IP: 192.168.2.50
Subnet Mask: 255.255.255.0
Gateway: 192.168.2.1
DNS1: 192.168.2.1

Local IP: 192.168.1.240
Subnet Mask: 255.255.255.0

Und jetzt wird's etwas komplizierter...

Normalerweise ist meine Fritz der Router in meinem Netzwerk. Das soll
auch so bleiben, weil darüber telefoniere ich ja. Im Netzwerk gibt es
zusàtzlich noch einen Rechner, der neben Mail- und Newsserver auch einen
dhcp-Server und einen DNS zur Verfügung stellt (über dnsmasq). Der
DNS-Server hat seine kleine eigene List und wenn die nicht mehr recht,
(weil die Anfrage nicht im eigenen Netz ist), dann leitet er die Anfrage
auf die Fritz Box weiter. Die Fritz wird auch als Standardgateway
vorgegeben.

Der Fritz habe ich nun einen Eintrag in der Routing-Tabelle verpaßt:
Netzwerk: 192.168.2.0
Subnet Mask: 255.255.255.0
Gateway: 192.168.1.240

Das heißt also, Anfragen an das Netz meiner Nachbarin werden über den
se505 geleitet - denke ich zumindest.

Was sollte ich unter /Setup/Basic Setup/Network Setup/ eintragen? Ich
habe schon versucht, den se505 UND den Router meiner Nachbarin
einzutragen. Beide mit gleichem Erfolg.

Nun, was soll ich sagen? Es klappt einfach nicht. Ich kann noch nichtmal
vom se505 aus (ssh) den Router meiner Nachbarin anpingen. Dummerweise
gibt es auch keine Fehlermeldungen. den syslogd habe ich gestartet.
/var/log/messages zeigt zwar reichlich an, aber nur das starten und
stoppen von Diensten. Da steht nicht, ob eine WLAN-Verbindung steht oder
nicht. Unter /Status/Wireless/ bleibt der Site Survey immer leer, egal
wie oft ich auf Refresh klicke. Wiviz Survey zeigt allerdings alle
Netzwerke an - auch das mit dem ich verbinden will.

Habe ich hier einen Denkfehler im System? Kann mir jemand einen Tipp
geben, wo ich zumindest an brauchbare Meldungen komme, damit ich weiß,
wo es hakt? Ich habe z.B. keine Ahnung, ob z.B. der Empfang nur zu
schlapp ist.

Gruß
Christian

Ich kam.
Ich ging.
Und ich war da gewesen.
 

Lesen sie die antworten

#1 Ralf Jeworowski
19/10/2008 - 18:09 | Warnen spam
Moin

Christian Baer schrieb:
[...Problem...]
Habe ich hier einen Denkfehler im System? Kann mir jemand einen Tipp
geben, wo ich zumindest an brauchbare Meldungen komme, damit ich weiß,
wo es hakt? Ich habe z.B. keine Ahnung, ob z.B. der Empfang nur zu
schlapp ist.




irgendwo vermisse ich da wieder die Sache mit "Portweiterleitung" etc.

Also,den SE505v1 wuerde ich zunaechst als Client[Client Bridge]
konfigurieren.
Behalten wir mal die IP 192.168.2.50 GW+DNS 192.168.2.1
DHCP AUS

So sollte schon mal der Internetzugang funktionieren

Nun habe ich die FB 7270 nicht zur Hand und der mir Speedport W920V ist
wenig hilfreich.
Du musst jetzt deine FB7250 am WAN Port mit einem Crosskabel oder Switch
mit dem SE505 verbinden und die IP auf Static stellen denn einwaehlen
soll er sich nicht.
Die FB 7270 bekommt nun am WAN Port Static 192.168.2.51 GW GW ist hier
192.168.2.50!!! Als DNS kannste dann wieder 192.168.2.1 nehmen.
LAN seitig kannste dann einen neuen IP Range nehmen und da auch wieder
den DHCP der FB einschalten.
Jetzt wieder die Internetverbindung testen,wenn bisher alles soweit
funktioniert musste vermutlich ueber alle drei Router/AP die
benoetigten Ports fuer VOIP/SIP durchleiten.
Bei mir funktioniert ein aehnliches Konstrukt aber da ist bei mir statt
deiner FB7270 ein PC dran.

-ralf-


Im Norden zuhause:54° 47' 24.10"N, 9° 25' 45.70"E
Bitte nur in die Newsgroup antworten.Die Mailadressen
sind gültig werden aber selten gelesen!

Ähnliche fragen